Fasguy's Website

Side-announcements

2020-09-05

Starting today, i will no longer be supporting any version of Internet Explorer for any of my websites. If you want to use any of my websites and you have problems using them, please get yourself a recent version of a modern browser (Chrome, Firefox, etc.).